package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]`)
var str = `I will always remember
The day you kissed my lips
Light as a feather
And it went just like this
No, it's never been better
Than the summer of 2002 (ooh)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}