import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z]";
final String string = "I will always remember\n"
+ "The day you kissed my lips\n"
+ "Light as a feather\n"
+ "And it went just like this\n"
+ "No, it's never been better\n"
+ "Than the summer of 2002 (ooh)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}