using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Modules = "".*?\b40\b.*?""";
string input = @"Modules = ""40,50,4""
Modules = ""30,40""
Modules = ""10,40,50""
Modules = ""400""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}