$re = '/Modules = ".*?\b40\b.*?"/m';
$str = 'Modules = "40,50,4"
Modules = "30,40"
Modules = "10,40,50"
Modules = "400"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);