// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)Modules = ".*?\b40\b.*?""#).unwrap();
let string = "Modules = \"40,50,4\"
Modules = \"30,40\"
Modules = \"10,40,50\"
Modules = \"400\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}