#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\"[^\"\n\r]*\"|\d+)(?:\h(?:\"[^\"\n\r]*\"|\d+))*\r?$"
Local $sString = ""Field1" "Field2" "Field3 Field_3.1 Field3.2" 23 3445 "Field5"" & @CRLF & _
""Field1 " " Field2" "Field3 Field_3.1 Field3.2" 23 3445 "Field5"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""Field1" "Field2" "Field3 Field_3.1 Field3.2" 23 3445 "Field5""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")