const regex = new RegExp('^(?:\\"[^\\"\\n\\r]*\\"|\\d+)(?:\\h(?:\\"[^\\"\\n\\r]*\\"|\\d+))*\\r?$', 'gm')
const str = `"Field1" "Field2" "Field3 Field_3.1 Field3.2" 23 3445 "Field5"
"Field1 " " Field2" "Field3 Field_3.1 Field3.2" 23 3445 "Field5"
"Field1" "Field2" "Field3 Field_3.1 Field3.2" 23 3445 "Field5"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}