import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\\"[^\\\"\\n\\r]*\\\"|\\d+)(?:\\h(?:\\\"[^\\\"\\n\\r]*\\\"|\\d+))*\\r?$";
final String string = "\"Field1\" \"Field2\" \"Field3 Field_3.1 Field3.2\" 23 3445 \"Field5\"\n"
+ "\"Field1 \" \" Field2\" \"Field3 Field_3.1 Field3.2\" 23 3445 \"Field5\"\n\n\n"
+ "\"Field1\" \"Field2\" \"Field3 Field_3.1 Field3.2\" 23 3445 \"Field5\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}