const regex = /\\"\d{1,3}cm\\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\"\\d{1,3}cm\\\\"', 'gm')
const str = `"<?xml version=\\"1.0\\" standalone=\\"no\\"?>",
"<svg xmlns=\\"http://www.w3.org/2000/svg\\" version=\\"1.1\\" width=\\"1250cm\\" height=\\"1250cm\\">",
"<desc>9W43OV00W8JKMA1IJNEYAM1WTG9AZH8K10LC</desc>",
"<g id=\\"HMLW03D1BYIQ\\" fill=\\"red\\">",
"<rect x=\\"252cm\\" y=\\"252cm\\" width=\\"252cm\\" height=\\"252cm\\"/>",
"<rect x=\\"72cm\\" y=\\"72cm\\" width=\\"72cm\\" height=\\"72cm\\"/>",
"<rect x=\\"131cm\\" y=\\"131cm\\" width=\\"131cm\\" height=\\"131cm\\"/>",
"<rect x=\\"228cm\\" y=\\"228cm\\" width=\\"228cm\\" height=\\"228cm\\"/>",
"<rect x=\\"240cm\\" y=\\"240cm\\" width=\\"240cm\\" height=\\"240cm\\"/>",
"<rect x=\\"232cm\\" y=\\"232cm\\" width=\\"232cm\\" height=\\"232cm\\"/>",
"<rect x=\\"192cm\\" y=\\"192cm\\" width=\\"192cm\\" height=\\"192cm\\"/>",
"<rect x=\\"0cm\\" y=\\"0cm\\" width=\\"0cm\\" height=\\"0cm\\"/>",
"<rect x=\\"0cm\\" y=\\"0cm\\" width=\\"0cm\\" height=\\"0cm\\"/>",
"<rect x=\\"0cm\\" y=\\"0cm\\" width=\\"0cm\\" height=\\"0cm\\"/>",
"<rect x=\\"65cm\\" y=\\"65cm\\" width=\\"65cm\\" height=\\"65cm\\"/>",
"<rect x=\\"81cm\\" y=\\"81cm\\" width=\\"81cm\\" height=\\"81cm\\"/>",
"<rect x=\\"65cm\\" y=\\"65cm\\" width=\\"65cm\\" height=\\"65cm\\"/>",
"<rect x=\\"80cm\\" y=\\"80cm\\" width=\\"80cm\\" height=\\"80cm\\"/>",
"<rect x=\\"82cm\\" y=\\"82cm\\" width=\\"82cm\\" height=\\"82cm\\"/>",
"<rect x=\\"81cm\\" y=\\"81cm\\" width=\\"81cm\\" height=\\"81cm\\"/>",
"</g>"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}