import re
regex = re.compile(r"^section_1:\s*(?<section_1>[a-z]+(?:\s&\s[a-z]+)*)\s*\|\s*section_2:\s*(?<section_2>[a-z]+(?:\s&\s[a-z]+)*)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Section_1: hello & goodbye | section_2: kuku\n"
"Section_1: hello & goodbye & hola | section_2: kuku\n"
"Section_1: hello | section_2: kuku\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")