use strict;
my $str = 'Mexico [12/20/1985]';
my $regex = qr/((?:19|20)\d\d)?./mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";