import re
regex = re.compile(r"((?:19|20)\d\d)?.", flags=re.MULTILINE)
test_str = "Mexico [12/20/1985]"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)