$re = '/((?:19|20)\d\d)?./m';
$str = 'Mexico [12/20/1985]';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;