package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d)\.(\d)\.?(\d)?\.?(\d)?\.?([a-z]{1,2})?(\d{1,3})?`)
var str = `1.0.1a0
1.0.2
1.0
1.0.1.1
1.0.1b1
1.0.3rc3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}