const regex = /(\d)\.(\d)\.?(\d)?\.?(\d)?\.?([a-z]{1,2})?(\d{1,3})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)\\.(\\d)\\.?(\\d)?\\.?(\\d)?\\.?([a-z]{1,2})?(\\d{1,3})?', 'gm')
const str = `1.0.1a0
1.0.2
1.0
1.0.1.1
1.0.1b1
1.0.3rc3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}