$re = '/(\d)\.(\d)\.?(\d)?\.?(\d)?\.?([a-z]{1,2})?(\d{1,3})?/m';
$str = '1.0.1a0
1.0.2
1.0
1.0.1.1
1.0.1b1
1.0.3rc3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);