using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^$|\b(?:bot|crawl|spider)\b";
string input = @"googlebot
bot
this is a crawl
a crawler
certain bots";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}