package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^$|\b(?:bot|crawl|spider)\b`)
var str = `googlebot
bot
this is a crawl
a crawler
certain bots`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}