$re = '/^$|\b(?:bot|crawl|spider)\b/m';
$str = 'googlebot
bot
this is a crawl
a crawler
certain bots';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);