#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(?:(?P<x>\D*?)(?=(?:\ -\ |$)))?" & @CRLF & _
"(?:.*?(?<=\ -\ )(?P<y>[^\d,\n]+)(?=,|$))?" & @CRLF & _
"(?:.*?(?P<z>\d{2}$))?" & @CRLF & _
"$"
Local $sString = "a" & @CRLF & _
"a - b" & @CRLF & _
"a - b-c" & @CRLF & _
"a - b, 12" & @CRLF & _
"a - 12" & @CRLF & _
"12" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")