import Foundation
let pattern = #"""
^
(?:(?P<x>\D*?)(?=(?:\ -\ |$)))?
(?:.*?(?<=\ -\ )(?P<y>[^\d,\n]+)(?=,|$))?
(?:.*?(?P<z>\d{2}$))?
$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
a
a - b
a - b-c
a - b, 12
a - 12
12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)