$re = '~^
(?:(?P<x>\D*?)(?=(?:\ -\ |$)))?
(?:.*?(?<=\ -\ )(?P<y>[^\d,\n]+)(?=,|$))?
(?:.*?(?P<z>\d{2}$))?
$~mx';
$str = 'a
a - b
a - b-c
a - b, 12
a - 12
12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);