import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bTo: ([^<>\\r\\n]+) <([a-z0-9_+.-]+@[a-z0-9-]+\\.[a-z]{2,4}(?:\\.[a-z]{2})?)>";
final String string = "Sent: 19 July 2019 14:25\n"
+ "To: John Dough <john@dough.zzz>\n\n"
+ "To: John Dough\n\n\n"
+ "To: John Dough <john@dough.zzz>\n\n\n"
+ "To: John Dough <john@dough.zzz>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}