$re = '/\bTo: ([^<>\r\n]+) <([a-z0-9_+.-]+@[a-z0-9-]+\.[a-z]{2,4}(?:\.[a-z]{2})?)>/m';
$str = 'Sent: 19 July 2019 14:25
To: John Dough <john@dough.zzz>
To: John Dough
To: John Dough <john@dough.zzz>
To: John Dough <john@dough.zzz>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);