// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bTo: ([^<>\r\n]+) <([a-z0-9_+.-]+@[a-z0-9-]+\.[a-z]{2,4}(?:\.[a-z]{2})?)>").unwrap();
let string = "Sent: 19 July 2019 14:25
To: John Dough <john@dough.zzz>
To: John Dough
To: John Dough <john@dough.zzz>
To: John Dough <john@dough.zzz>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}