#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^\d\r\n]+?)(?:\h*(\d.*)|$)"
Local $sString = "Lievensberg 31D" & @CRLF & _
"Jablunkovska 21/2" & @CRLF & _
"Weimarstraat 113 A" & @CRLF & _
"Pastoor Baltesenstraat 22" & @CRLF & _
"Van Musschenboek strasse 84" & @CRLF & _
"Lievensberg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")