import re
regex = re.compile(r"^([^\d\r\n]+?)(?:\h*(\d.*)|$)", flags=re.MULTILINE)
test_str = ("Lievensberg 31D\n"
"Jablunkovska 21/2\n"
"Weimarstraat 113 A\n"
"Pastoor Baltesenstraat 22\n"
"Van Musschenboek strasse 84\n"
"Lievensberg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")