re = /^([^\d\r\n]+?)(?:\h*(\d.*)|$)/m
str = 'Lievensberg 31D
Jablunkovska 21/2
Weimarstraat 113 A
Pastoor Baltesenstraat 22
Van Musschenboek strasse 84
Lievensberg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end