const regex = /[A-Z]+(?:\.\d+){2,3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]+(?:\\.\\d+){2,3}', 'gm')
const str = `A.1.1
AA.1.1
AE.5.10
Z.10.10.1
BV.1.6.10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}