$re = '/[A-Z]+(?:\.\d+){2,3}/m';
$str = 'A.1.1
AA.1.1
AE.5.10
Z.10.10.1
BV.1.6.10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);