// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]+(?:\.\d+){2,3}").unwrap();
let string = "A.1.1
AA.1.1
AE.5.10
Z.10.10.1
BV.1.6.10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}