import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.(?=.*\\n(\\1?+.)))*?(?=Size)(?:\\w\\B(?=.*\\n\\1?+(\\2?+\\D)))*+.*\\n\\1?+\\2?+(?<![\\d.])\\K[\\d.]+";
final String string = "Property Size\n"
+ "Jerusale811.00\n\n"
+ "Property Size\n"
+ "Jerusalem811.00\n\n"
+ "Property Size\n"
+ "Jerusalem 811.00\n\n"
+ "Property Size\n"
+ "Jerusalem 811.00\n\n"
+ "Property Size\n"
+ "Jerusalem 811.00\n\n"
+ "Property Size\n"
+ "Jerusalem 811.00\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}