const regex = /^(?:.(?=.*\n(\1?+.)))*?(?=Size)(?:\w\B(?=.*\n\1?+(\2?+\D)))*+.*\n\1?+\2?+(?<![\d.])\K[\d.]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.(?=.*\\n(\\1?+.)))*?(?=Size)(?:\\w\\B(?=.*\\n\\1?+(\\2?+\\D)))*+.*\\n\\1?+\\2?+(?<![\\d.])\\K[\\d.]+', 'gm')
const str = `Property Size
Jerusale811.00
Property Size
Jerusalem811.00
Property Size
Jerusalem 811.00
Property Size
Jerusalem 811.00
Property Size
Jerusalem 811.00
Property Size
Jerusalem 811.00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}