package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)chicken '(.*?)'`)
var str = `hello, i like to eat beef 'sandwiches' and beef 'jerky' and chicken 'patties' and chicken 'burgers' and also chicken 'fingers' and other chicken 'meat' too.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}