re = /chicken '(.*?)'/m
str = 'hello, i like to eat beef \'sandwiches\' and beef \'jerky\' and chicken \'patties\' and chicken \'burgers\' and also chicken \'fingers\' and other chicken \'meat\' too.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end