$re = '/chicken \'(.*?)\'/m';
$str = 'hello, i like to eat beef \'sandwiches\' and beef \'jerky\' and chicken \'patties\' and chicken \'burgers\' and also chicken \'fingers\' and other chicken \'meat\' too.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);