using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\w+=\w*|=\w+)(?:&(?:\w+=\w*|=\w+))*$";
string input = @"one=1&two=2&=3&tr=";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}