package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:\w+=\w*|=\w+)(?:&(?:\w+=\w*|=\w+))*$`)
var str = `one=1&two=2&=3&tr=`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}