using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<img.*?src=[""']).+(?=[""'].*?>)";
string input = @"sdfsdsd <img sds src='fjkldjfkl1d' sdsd>
fsdfsdsfg
<img gdfgd src='fjkldjfkld'g ggdfggfd/>
ddfd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}