re = /(?<=<img.*?src=["']).+(?=["'].*?>)/m
str = 'sdfsdsd <img sds src=\'fjkldjfkl1d\' sdsd>
fsdfsdsfg
<img gdfgd src=\'fjkldjfkld\'g ggdfggfd/>
ddfd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end