$re = '/(?<=<img.*?src=["\']).+(?=["\'].*?>)/m';
$str = 'sdfsdsd <img sds src=\'fjkldjfkl1d\' sdsd>
fsdfsdsfg
<img gdfgd src=\'fjkldjfkld\'g ggdfggfd/>
ddfd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);