using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|\b(\w+)(?= +\1\b) +|\G(?!^)(\w+))";
string input = @"pds dd dd dd dd sd dd ss ss dd ee ee ee ee ee ee ee";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}