$re = '/(?|\b(\w+)(?= +\1\b) +|\G(?!^)(\w+))/m';
$str = 'pds dd dd dd dd sd dd ss ss dd ee ee ee ee ee ee ee';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);