const regex = new RegExp('/NN\\S+? \\S+?/VB/B-VP\\S+? \\S+?/NN', 'gm')
const str = `dogs /NNS/B-NP/O eat/VB/B-VP/O bones/NNS/B-NP/O ././O/O
it/PRP/B-NP/O '/POS/O/O s/PRP/B-NP/O a/DT/I-NP/O performance/NN/I-NP/O they/PRP/I-NP/O put/VB/B-VP/O on/IN/B-PP/B-PNP at/IN/I-PP/I-PNP her/PRP\$/B-NP/I-PNP school/NN/I-NP/I-PNP
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}