// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/NN\S+? \S+?/VB/B-VP\S+? \S+?/NN").unwrap();
let string = "dogs /NNS/B-NP/O eat/VB/B-VP/O bones/NNS/B-NP/O ././O/O
it/PRP/B-NP/O '/POS/O/O s/PRP/B-NP/O a/DT/I-NP/O performance/NN/I-NP/O they/PRP/I-NP/O put/VB/B-VP/O on/IN/B-PP/B-PNP at/IN/I-PP/I-PNP her/PRP$/B-NP/I-PNP school/NN/I-NP/I-PNP
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}