$re = '//NN\S+? \S+?/VB/B-VP\S+? \S+?/NN/m';
$str = 'dogs /NNS/B-NP/O eat/VB/B-VP/O bones/NNS/B-NP/O ././O/O
it/PRP/B-NP/O \'/POS/O/O s/PRP/B-NP/O a/DT/I-NP/O performance/NN/I-NP/O they/PRP/I-NP/O put/VB/B-VP/O on/IN/B-PP/B-PNP at/IN/I-PP/I-PNP her/PRP$/B-NP/I-PNP school/NN/I-NP/I-PNP
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);