using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?'match'.*)\)";
string input = @"ab(cde)fg
ab(c(d)e)fg
ab((c(d)(efg)hi(jk)lmnop))qr
ab()cd";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}