$re = '/\((?\'match\'.*)\)/';
$str = 'ab(cde)fg
ab(c(d)e)fg
ab((c(d)(efg)hi(jk)lmnop))qr
ab()cd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);