package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?'match'.*)\)`)
var str = `ab(cde)fg
ab(c(d)e)fg
ab((c(d)(efg)hi(jk)lmnop))qr
ab()cd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}