package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\([^+]*\)|\(-?\d+\+-?\d+\)`)
var str = `[-4,1]+[-7,1]*([3,5]-([-1,2]*[4,5]-[0,2]))+(3+4)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}